トップ 差分 一覧 ソース 検索 ヘルプ PDF RSS ログイン

20080911、debian上にPHPのeclipse環境(PDT)を構築してみます。

[カテゴリ:debian]
[カテゴリ:lenny]
[カテゴリ:php]

debian上にPHPのeclipse環境(PDT)を構築してみます。 - gounx2の日記
http://d.hatena.ne.jp/gounx2/20090812/1250085132

の作業ログ

goun@debianlenny:~$ dpkg -l | egrep "apache|php"
ii  apache2                              2.2.9-10+lenny4            Apache HTTP Server metapackage
ii  apache2-doc                          2.2.9-10+lenny4            Apache HTTP Server documentation
ii  apache2-mpm-prefork                  2.2.9-10+lenny4            Apache HTTP Server - traditional non-threaded model
ii  apache2-utils                        2.2.9-10+lenny4            utility programs for webservers
ii  apache2.2-common                     2.2.9-10+lenny4            Apache HTTP Server common files
ii  libapache2-mod-perl2                 2.0.4-5                    Integration of perl with the Apache2 web server
ii  libapache2-mod-php5                  5.2.6.dfsg.1-1+lenny3      server-side, HTML-embedded scripting language (Apache 2 module
ii  libapache2-mod-python                3.3.1-7                    Python-embedding module for Apache 2
ii  php5-common                          5.2.6.dfsg.1-1+lenny3      Common files for packages built from the php5 source
goun@debianlenny:~$ 


goun@debianlenny:~$ dpkg -l | grep java
ii  java-common                          0.30                       Base of all Java packages
ii  java-gcj-compat                      1.0.78-2                   Java runtime environment using GIJ
ii  java-gcj-compat-headless             1.0.78-2                   Java runtime environment using GIJ (headless version)
ii  libbcel-java                         5.2-3                      Analyze, create, and manipulate (binary) Java class files
ii  libhsqldb-java                       1.8.0.9-3                  Java SQL database engine
ii  libhsqldb-java-gcj                   1.8.0.9-3                  Java SQL database engine (native code)
ii  libjaxp1.3-java                      1.3.04-3                   Java XML parser and transformer APIs (DOM, SAX, JAXP, TrAX)
ii  libjaxp1.3-java-gcj                  1.3.04-3                   Java XML parser and transformer APIs (DOM, SAX, JAXP, TrAX)
ii  libjline-java                        0.9.94-1                   Java library for handling console input
ii  liblog4j1.2-java                     1.2.15-4                   Logging library for java
ii  libmx4j-java                         3.0.2-4                    An open source implementation of the JMX(TM) technology
ii  libregexp-java                       1.4-5                      regular expression library for Java
ii  libservlet2.4-java                   5.0.30-8                   Servlet 2.4 and JSP 2.0 Java classes and documentation
ii  libxalan2-java                       2.7.1-2                    XSL Transformations (XSLT) processor in Java
ii  libxalan2-java-gcj                   2.7.1-2                    XSL Transformations (XSLT) processor in Java (native code)
ii  libxerces2-java                      2.9.1-2                    Validating XML parser for Java with DOM level 3 support
ii  libxerces2-java-gcj                  2.9.1-2                    Validating XML parser for Java with DOM level 3 support (nativ
ii  openoffice.org-java-common           1:2.4.1+dfsg-1             OpenOffice.org office suite Java support arch. independent fil
goun@debianlenny:~$ 


D: AptGet - Debian GNU/Linux スレッドテンプレ
http://debian.fam.cx/index.php?AptGet

AptPinning - Debian Wiki
http://wiki.debian.org/AptPinning


D: Software/Java - Debian GNU/Linux スレッドテンプレ
http://debian.fam.cx/index.php?cmd=read&page=Software%2FJava


goun@debianlenny:~$ which java
/usr/bin/java
goun@debianlenny:~$ ls -al `which java`
lrwxrwxrwx 1 root root 22 2009-07-03 22:21 /usr/bin/java -> /etc/alternatives/java
goun@debianlenny:~$ ls -al /etc/alternatives/java
lrwxrwxrwx 1 root root 34 2009-08-11 22:32 /etc/alternatives/java -> /usr/lib/jvm/java-gcj/jre/bin/java
goun@debianlenny:~$ 
goun@debianlenny:~$ java --version
java version "1.5.0"
gij (GNU libgcj) version 4.3.2

Copyright (C) 2007 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
goun@debianlenny:~$ 




goun@debianlenny:/nilfs/ecl3.5pdt2.1/eclipse$ aptitude show eclipse
 "eclipse" パッケージのアーカイブ "lenny" が見つかりません
パッケージ: eclipse
状態: インストールされていません
バージョン: 3.2.2-6.1
優先度: 任意
セクション: devel
メンテナ: Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
展開サイズ: 426k
依存: eclipse-jdt (= 3.2.2-6.1), eclipse-pde (= 3.2.2-6.1), eclipse-source (= 3.2.2-6.1), zenity, libc6 (>=
        2.7-1), libglib2.0-0 (>= 2.12.0), libgtk2.0-0 (>= 2.12.0)
推奨: eclipse-gcj
競合: eclipse-platform-common (< 3.1.2-1), eclipse-sdk (<= 3.1.1-5)
置換: eclipse-platform (< 3.1.2-2), eclipse-platform-common (< 3.1.2-1), eclipse-sdk (<= 3.1.1-5)
説明: Extensible Tool Platform and Java IDE
 The Eclipse Platform is an open and extensible platform for anything and yet nothing in particular. It
 provides a foundation for constructing and running integrated software-development tools. The Eclipse Platform
 allows tool builders to independently develop tools that integrate with other people's tools so seamlessly you
 can't tell where one tool ends and another starts. 
 
 Package to provide the whole Eclipse SDK, which includes the Java Development Tools and Plug-in Development
 Tools.
ホームページ: http://www.eclipse.org/

goun@debianlenny:/nilfs/ecl3.5pdt2.1/eclipse$ 









goun@debianlenny:~$ sudo vi /etc/apt/sources.list
:
deb http://ftp.jp.debian.org/debian/ lenny main non-free
deb-src http://ftp.jp.debian.org/debian/ lenny main non-free

deb http://security.debian.org/ lenny/updates main non-free
deb-src http://security.debian.org/ lenny/updates main non-free




goun@debianlenny:~$ sudo aptitude update
:



goun@debianlenny:~$ aptitude show sun-java6-jre
 "sun-java6-jre" パッケージのアーカイブ "lenny" が見つかりません
パッケージ: sun-java6-jre
新規: yes
状態: インストールされていません
バージョン: 6-12-1
優先度: 任意
セクション: non-free/libs
メンテナ: Matthias Klose <doko@ubuntu.com>
展開サイズ: 14.6M
依存: java-common (>= 0.24), locales, sun-java6-bin (= 6-12-1) | ia32-sun-java6-bin (= 6-12-1)
事前依存: debconf (>= 0.5) | debconf-2.0
推奨: gsfonts-x11
提案: sun-java6-plugin | ia32-sun-java6-plugin, sun-java6-fonts, ttf-baekmuk | ttf-unfonts | ttf-unfonts-core,
        ttf-kochi-gothic | ttf-sazanami-gothic, ttf-kochi-mincho | ttf-sazanami-mincho, ttf-arphic-uming
競合: j2se-common
置換: ia32-sun-java6-bin, sun-java6-bin
提供: java-runtime, java-runtime-headless, java-virtual-machine, java2-runtime, java2-runtime-headless,
        java5-runtime, java5-runtime-headless, java6-runtime, java6-runtime-headless
説明: Sun Java(TM) Runtime Environment (JRE) 6 (architecture independent files)
 The Sun Java Platform Standard Edition Runtime Environment (JRE) 6 contains the Java virtual machine, runtime
 class libraries, and Java application launcher that are necessary to run programs written in the Java
 progamming language. It is not a development environment and doesn't contain development tools such as
 compilers or debuggers. For development tools, see the Java Development Kit JDK(TM) 6 (package sun-java6-jdk).
 
 NOTE: You must accept Sun's EULA prior to successfully installing this package 
 
 This package contains architecture independent files.
ホームページ: http://java.sun.com/javase/

goun@debianlenny:~$ 



goun@debianlenny:~$ sudo aptitude install sun-java6-jre
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
拡張状態情報を読み込んでいます      
パッケージの状態を初期化しています... 完了
タスクの記述を読み込んでいます... 完了        
以下の新規パッケージがインストールされます:
  gsfonts-x11{a} odbcinst1debian1{a} sun-java6-bin{a} sun-java6-jre unixodbc{a} 
更新: 0 個、新規インストール: 5 個、削除: 0 個、保留: 5 個。
35.0MB のアーカイブを取得する必要があります。展開後に 100MB のディスク領域が新たに消費されます。
先に進みますか? [Y/n/?] 
:



goun@debianlenny:~$ dpkg -L java-common
/.
/usr
/usr/sbin
/usr/sbin/update-java-alternatives
:

goun@debianlenny:~$ sudo update-java-alternatives
usage: update-java-alternatives [--jre-headless] [--jre] [--plugin] [ -t|--test|-v|--verbose]
           -l|--list [<jname>]
           -s|--set <jname>
           -a|--auto
           -h|-?|--help
goun@debianlenny:~$ sudo update-java-alternatives -l
java-6-sun 63 /usr/lib/jvm/java-6-sun
java-gcj 1042 /usr/lib/jvm/java-gcj
goun@debianlenny:~$ 




goun@debianlenny:~$ sudo update-java-alternatives -l
java-6-sun 63 /usr/lib/jvm/java-6-sun
java-gcj 1042 /usr/lib/jvm/java-gcj
goun@debianlenny:~$ 
goun@debianlenny:~$ 
goun@debianlenny:~$ 
goun@debianlenny:~$ sudo update-java-alternatives -s java-6-sun
HtmlConverter の alternatives がありません。
appletviewer の alternatives がありません。
apt の alternatives がありません。
extcheck の alternatives がありません。
firefox-3.0-javaplugin.so の alternatives がありません。
firefox-javaplugin.so の alternatives がありません。
iceape-javaplugin.so の alternatives がありません。
iceweasel-javaplugin.so の alternatives がありません。
idlj の alternatives がありません。
jarsigner の alternatives がありません。
java-rmi.cgi の alternatives がありません。
javac の alternatives がありません。
javadoc の alternatives がありません。
javah の alternatives がありません。
javap の alternatives がありません。
jconsole の alternatives がありません。
jdb の alternatives がありません。
jhat の alternatives がありません。
jinfo の alternatives がありません。
jmap の alternatives がありません。
jps の alternatives がありません。
jrunscript の alternatives がありません。
jsadebugd の alternatives がありません。
jstack の alternatives がありません。
jstat の alternatives がありません。
jstatd の alternatives がありません。
midbrowser-javaplugin.so の alternatives がありません。
mozilla-javaplugin.so の alternatives がありません。
native2ascii の alternatives がありません。
rmic の alternatives がありません。
schemagen の alternatives がありません。
wsgen の alternatives がありません。
wsimport の alternatives がありません。
xjc の alternatives がありません。
xulrunner-1.9-javaplugin.so の alternatives がありません。
xulrunner-javaplugin.so の alternatives がありません。
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/HtmlConverter
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/appletviewer
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/apt
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/extcheck
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/idlj
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/jar
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/jarsigner
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/java-rmi.cgi
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/javac
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/javadoc
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/javah
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/javap
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/jconsole
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/jdb
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/jhat
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/jinfo
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/jmap
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/jps
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/jrunscript
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/jsadebugd
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/jstack
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/jstat
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/jstatd
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/native2ascii
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/rmic
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/schemagen
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/serialver
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/wsgen
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/wsimport
update-java-alternatives: jdk alternative does not exist: /usr/lib/jvm/java-6-sun/bin/xjc
'ControlPanel' を提供するために '/usr/lib/jvm/java-6-sun/jre/bin/ControlPanel' を使います。
'java' を提供するために '/usr/lib/jvm/java-6-sun/jre/bin/java' を使います。
'java_vm' を提供するために '/usr/lib/jvm/java-6-sun/jre/bin/java_vm' を使います。
'javaws' を提供するために '/usr/lib/jvm/java-6-sun/jre/bin/javaws' を使います。
'jcontrol' を提供するために '/usr/lib/jvm/java-6-sun/jre/bin/jcontrol' を使います。
'jexec' を提供するために '/usr/lib/jvm/java-6-sun/jre/lib/jexec' を使います。
'keytool' を提供するために '/usr/lib/jvm/java-6-sun/jre/bin/keytool' を使います。
'orbd' を提供するために '/usr/lib/jvm/java-6-sun/jre/bin/orbd' を使います。
'pack200' を提供するために '/usr/lib/jvm/java-6-sun/jre/bin/pack200' を使います。
'policytool' を提供するために '/usr/lib/jvm/java-6-sun/jre/bin/policytool' を使います。
'rmid' を提供するために '/usr/lib/jvm/java-6-sun/jre/bin/rmid' を使います。
'rmiregistry' を提供するために '/usr/lib/jvm/java-6-sun/jre/bin/rmiregistry' を使います。
'servertool' を提供するために '/usr/lib/jvm/java-6-sun/jre/bin/servertool' を使います。
'tnameserv' を提供するために '/usr/lib/jvm/java-6-sun/jre/bin/tnameserv' を使います。
'unpack200' を提供するために '/usr/lib/jvm/java-6-sun/jre/bin/unpack200' を使います。
firefox-javaplugin.so の alternatives がありません。
iceape-javaplugin.so の alternatives がありません。
iceweasel-javaplugin.so の alternatives がありません。
midbrowser-javaplugin.so の alternatives がありません。
mozilla-javaplugin.so の alternatives がありません。
xulrunner-1.9-javaplugin.so の alternatives がありません。
xulrunner-javaplugin.so の alternatives がありません。
goun@debianlenny:~$ 

goun@debianlenny:~$ java -version
java version "1.6.0_12"
Java(TM) SE Runtime Environment (build 1.6.0_12-b04)
Java HotSpot(TM) Client VM (build 11.2-b01, mixed mode, sharing)
goun@debianlenny:~$ 




PHP Development Tools (PDT) - Downloads
http://www.eclipse.org/pdt/downloads/

 PDT 2.1 All In Ones / Eclipse PHP Package
 
 These downloads include PDT 2.1, Eclipse 3.5, Mylyn and all other required plugins.
 :
   *All-In-One Linux x86/GTK 2 32-bit 139M

goun@debianlenny:/nilfs/eclipse$ wget "http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/galileo/R/eclipse-php-galileo-linux-gtk.tar.gz&url=http://ftp.yz.yamagata-u.ac.jp/pub/eclipse//technology/epp/downloads/release/galileo/R/eclipse-php-galileo-linux-gtk.tar.gz&mirror_id=533"
--2009-08-11 23:07:14--  http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/galileo/R/eclipse-php-galileo-linux-gtk.tar.gz&url=http://ftp.yz.yamagata-u.ac.jp/pub/eclipse//technology/epp/downloads/release/galileo/R/eclipse-php-galileo-linux-gtk.tar.gz&mirror_id=533
www.eclipse.org をDNSに問いあわせています... 206.191.52.46
www.eclipse.org|206.191.52.46|:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 302 Found
場所: http://ftp.yz.yamagata-u.ac.jp/pub/eclipse//technology/epp/downloads/release/galileo/R/eclipse-php-galileo-linux-gtk.tar.gz [続く]
--2009-08-11 23:07:16--  http://ftp.yz.yamagata-u.ac.jp/pub/eclipse//technology/epp/downloads/release/galileo/R/eclipse-php-galileo-linux-gtk.tar.gz
ftp.yz.yamagata-u.ac.jp をDNSに問いあわせています... 133.24.255.161, 203.178.129.178, 203.178.129.179, ...
ftp.yz.yamagata-u.ac.jp|133.24.255.161|:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 200 OK
長さ: 144634139 (138M) [application/x-gzip]
`eclipse-php-galileo-linux-gtk.tar.gz' に保存中

100%[=====================================================================>] 144,634,139  726K/s 時間 3m 34s  

2009-08-11 23:10:49 (662 KB/s) - `eclipse-php-galileo-linux-gtk.tar.gz' へ保存完了 [144634139/144634139]

goun@debianlenny:/nilfs/eclipse$ 



goun@debianlenny:/nilfs/eclipse$ tar zxvf eclipse-php-galileo-linux-gtk.tar.gz 
:


goun@debianlenny:/nilfs$ sudo mv eclipse ecl3.5pdt2.1
goun@debianlenny:/nilfs/ecl3.5pdt2.1/eclipse$ ./eclipse &
[1] 23688
goun@debianlenny:/nilfs/ecl3.5pdt2.1/eclipse$ 









Pleiades - Eclipse プラグイン日本語化プラグイン
http://mergedoc.sourceforge.jp/pleiades.html

 Pleiades 本体ダウンロード
  既にインストール済みの Eclipse に適用したい場合や、Windows 以外で使用する場合は
  下記の Pleiades 本体のみをダウンロードしてください。Pleiades のソースを Eclipse
  プロジェクトとしてチェックアウトする場合は こちら を参照してください。
  
   *安定版  1.3.0


http://sourceforge.jp/frs/redir.php?m=iij&f=%2Fmergedoc%2F38225%2Fpleiades_1.3.0.zip



goun@debianlenny:/nilfs/ecl3.5pdt2.1$ wget "http://sourceforge.jp/frs/redir.php?m=iij&f=%2Fmergedoc%2F38225%2Fpleiades_1.3.0.zip"
--2009-08-12 02:08:18--  http://sourceforge.jp/frs/redir.php?m=iij&f=%2Fmergedoc%2F38225%2Fpleiades_1.3.0.zip
sourceforge.jp をDNSに問いあわせています... 202.221.179.21
sourceforge.jp|202.221.179.21|:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 302 Found
場所: http://globalbase.dl.sourceforge.jp/mergedoc/38225/pleiades_1.3.0.zip [続く]
--2009-08-12 02:08:18--  http://globalbase.dl.sourceforge.jp/mergedoc/38225/pleiades_1.3.0.zip
globalbase.dl.sourceforge.jp をDNSに問いあわせています... 202.231.40.73
globalbase.dl.sourceforge.jp|202.231.40.73|:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 200 OK
長さ: 8891581 (8.5M) [application/zip]
`pleiades_1.3.0.zip' に保存中

100%[=====================================================================>] 8,891,581   3.17M/s 時間 2.7s    

2009-08-12 02:08:21 (3.17 MB/s) - `pleiades_1.3.0.zip' へ保存完了 [8891581/8891581]

goun@debianlenny:/nilfs/ecl3.5pdt2.1$ 







goun@debianlenny:/usr/local$ sudo mkdir eclipse
goun@debianlenny:/usr/local$ sudo mv *gz *zip eclipse/
goun@debianlenny:/usr/local$ 
goun@debianlenny:/usr/local$ cd eclipse
goun@debianlenny:/usr/local/eclipse$ ls -al
合計 150100
drwxr-sr-x  2 root staff      4096 2009-08-12 18:41 .
drwxrwsr-x 11 root staff      4096 2009-08-12 18:41 ..
-rw-r--r--  1 root staff 144634139 2009-08-12 18:38 eclipse-php-galileo-linux-gtk.tar.gz
-rw-r--r--  1 root staff   8891581 2009-08-12 18:38 pleiades_1.3.0.zip
goun@debianlenny:/usr/local/eclipse$ 
goun@debianlenny:/usr/local/eclipse$ sudo tar zxvf eclipse-php-galileo-linux-gtk.tar.gz 
:
goun@debianlenny:/usr/local/eclipse$ ls -al
合計 150104
drwxr-sr-x  3 root    staff      4096 2009-08-12 18:43 .
drwxrwsr-x 11 root    staff      4096 2009-08-12 18:41 ..
drwxrwsr-x  9 libuuid users      4096 2009-06-19 17:52 eclipse
-rw-r--r--  1 root    staff 144634139 2009-08-12 18:38 eclipse-php-galileo-linux-gtk.tar.gz
-rw-r--r--  1 root    staff   8891581 2009-08-12 18:38 pleiades_1.3.0.zip
goun@debianlenny:/usr/local/eclipse$ sudo chown -R root:staff eclipse
goun@debianlenny:/usr/local/eclipse$ ls -al
合計 150104
drwxr-sr-x  3 root staff      4096 2009-08-12 18:43 .
drwxrwsr-x 11 root staff      4096 2009-08-12 18:41 ..
drwxrwsr-x  9 root staff      4096 2009-06-19 17:52 eclipse
-rw-r--r--  1 root staff 144634139 2009-08-12 18:38 eclipse-php-galileo-linux-gtk.tar.gz
-rw-r--r--  1 root staff   8891581 2009-08-12 18:38 pleiades_1.3.0.zip
goun@debianlenny:/usr/local/eclipse$ sudo sh -c "cd eclipse; unzip ../pleiades_1.3.0.zip"
Archive:  ../pleiades_1.3.0.zip
   creating: features/jp.sourceforge.mergedoc.pleiades/
   creating: features/jp.sourceforge.mergedoc.pleiades/META-INF/
   creating: plugins/jp.sourceforge.mergedoc.pleiades/
   creating: plugins/jp.sourceforge.mergedoc.pleiades/META-INF/
   creating: plugins/jp.sourceforge.mergedoc.pleiades/conf/
   creating: plugins/jp.sourceforge.mergedoc.pleiades/conf/additions/
   creating: plugins/jp.sourceforge.mergedoc.pleiades/lib/
   creating: plugins/jp.sourceforge.mergedoc.pleiades/lib/apache/
   creating: plugins/jp.sourceforge.mergedoc.pleiades/lib/javassist/
  inflating: eclipse.exe -clean.cmd  
  inflating: eclipse.exe startup.cmd  
  inflating: features/jp.sourceforge.mergedoc.pleiades/META-INF/MANIFEST.MF  
  inflating: features/jp.sourceforge.mergedoc.pleiades/META-INF/MERGEDOC.DSA  
  inflating: features/jp.sourceforge.mergedoc.pleiades/META-INF/MERGEDOC.SF  
  inflating: features/jp.sourceforge.mergedoc.pleiades/feature.properties  
  inflating: features/jp.sourceforge.mergedoc.pleiades/feature.xml  
  inflating: features/jp.sourceforge.mergedoc.pleiades/pleiades.png  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/META-INF/MANIFEST.MF  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/META-INF/MERGEDOC.DSA  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/META-INF/MERGEDOC.SF  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/about.html  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/about.ini  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/about.properties  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/conf/.marker  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/conf/additions/_readme.txt  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/conf/pleiades-config.xml  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/conf/splash.bmp  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/conf/splash3.2.bmp  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/conf/splash3.3.bmp  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/conf/splash3.4.bmp  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/conf/splash3.5.bmp  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/conf/translation-converter_sample.properties  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/conf/translation-exclude-package.properties  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/conf/translation-help-exclude.properties  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/conf/translation-help-html.properties  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/conf/translation-multibytes-key.properties  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/conf/translation-notfound-exclud.list  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/conf/translation-regex-through.properties  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/conf/translation-regex.properties  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/conf/translation.properties  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/epl-v10.html  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/featureImage.png  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/lib/apache/LICENSE.txt  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/lib/apache/commons-io-version-1.4  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/lib/apache/commons-io.jar  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/lib/apache/commons-lang-version-2.4  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/lib/apache/commons-lang.jar  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/lib/javassist/License.html  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/lib/javassist/javassist-version-3.9GA  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/lib/javassist/javassist.jar  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/pleiades.jar  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/plugin.properties  
  inflating: plugins/jp.sourceforge.mergedoc.pleiades/plugin.xml  
  inflating: readme/eclipse.ini_sample.win.3.1-3.2  
  inflating: readme/eclipse.ini_sample.win.3.3  
  inflating: readme/eclipse.ini_sample.win.3.4  
  inflating: readme/readme_pleiades.txt  
  inflating: readme/readme_pleiades_changes.txt  
goun@debianlenny:/usr/local/eclipse$ 
goun@debianlenny:/usr/local/eclipse$ sudo mv eclipse ecl3.5pdt2.1
goun@debianlenny:/usr/local/eclipse$ sudo vi ecl3.5pdt2.1/eclipse.ini 
-startup
plugins/org.eclipse.equinox.launcher_1.0.200.v20090520.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0.200.v20090520
-product
org.eclipse.epp.package.php.product
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
-vmargs
-Dosgi.requiredJavaVersion=1.5
-XX:MaxPermSize=256m
-Xms40m
-Xmx256m
--pleiades
-javaagent:plugins/jp.sourceforge.mergedoc.pleiades/pleiades.jar

goun@debianlenny:/nilfs/ecl3.5pdt2.1$ (cd eclipse; ./eclipse) &
goun@debianlenny:/usr/local/eclipse$ sudo sh -c "cat > /usr/local/bin/eclipse-pdt"
#!/bin/bash
#
# eclipse 起動
#

HOME_ECLIPSE=/usr/local/eclipse/ecl3.5pdt2.1

cd $HOME_ECLIPSE
./eclipse "$@"

goun@debianlenny:/usr/local/eclipse$ 
goun@debianlenny:/usr/local/eclipse$ sudo chmod a+x /usr/local/bin/eclipse-pdt 



goun@debianlenny:/usr/local/eclipse$ eclipse-pdt &

最終更新時間:2009年08月13日 00時30分55秒